• strict warning: Non-static method view::load() should not be called statically in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/views.module on line 906.
  • strict warning: Declaration of views_handler_filter::options_validate() should be compatible with views_handler::options_validate($form, &$form_state) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/handlers/views_handler_filter.inc on line 607.
  • strict warning: Declaration of views_handler_filter::options_submit() should be compatible with views_handler::options_submit($form, &$form_state) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/handlers/views_handler_filter.inc on line 607.
  • strict warning: Declaration of views_handler_filter_boolean_operator::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/handlers/views_handler_filter_boolean_operator.inc on line 159.
  • strict warning: Declaration of views_plugin_row::options_validate() should be compatible with views_plugin::options_validate(&$form, &$form_state) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/plugins/views_plugin_row.inc on line 134.
  • strict warning: Declaration of views_plugin_row::options_submit() should be compatible with views_plugin::options_submit(&$form, &$form_state) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/plugins/views_plugin_row.inc on line 134.
  • strict warning: Non-static method view::load() should not be called statically in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/views.module on line 906.
  • strict warning: Declaration of views_handler_field_user::init() should be compatible with views_handler_field::init(&$view, $options) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/modules/user/views_handler_field_user.inc on line 47.
  • strict warning: Declaration of views_plugin_style_default::options() should be compatible with views_object::options() in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/plugins/views_plugin_style_default.inc on line 24.
  • strict warning: Non-static method view::load() should not be called statically in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/views.module on line 906.
  • strict warning: Declaration of views_handler_argument::init() should be compatible with views_handler::init(&$view, $options) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/handlers/views_handler_argument.inc on line 744.
  • strict warning: Non-static method view::load() should not be called statically in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/views.module on line 906.
  • strict warning: Declaration of views_handler_filter_node_status::operator_form() should be compatible with views_handler_filter::operator_form(&$form, &$form_state) in /var/www/barcelona2012.drupaldays.org/releases/untagged_oldserver/profiles/cod/modules/contrib/views/modules/node/views_handler_filter_node_status.inc on line 13.

Drush Workshop

Drush is a command-line shell and scripting interface for Drupal. It provides a set of commands which act as shortcuts to perform common tasks with Drupal sites. The purpose of this workshop is to go through its installation, explain the most used commands and show how it can be customised and extended.

Who this workshop is for

Drupal developers or themers who understand Drupal administration’s basic concepts. Drush can make building any kind of website quicker and easier, no matter if it is a development environment, beta, a simple blog or a complex system.

Slides

Please have a look at the slides that will introduce the topics covered in this session. This is a work in progress presentation so any comments with suggestions or questions are more than welcome.

Requirements

  • Operative System. Any Unix-based system such as Ubuntu or MAC OS X. Windows users are welcome but notice that some Drush commands are not supported on Windows.
  • Software. PHP 5.2 or higher, MySQL 5.0 or higher, Apache 2.0 or higher, Drupal 7 (recommended) and Git.
  • Experience with the command line's basic commands. Knowledge of Public Key Authentication is a plus.

Drush workshop - Juampy from Asociación Drupal on Vimeo.

Slides: 

Schedule info

Time slot: 
16 June 12:00 - 13:00
Room: 
Omega8.cc Room
Track: 
Development
Experience level: 
Intermediate